After Effects tutorial #6 Dancing Particles – Reflection

 

Part 1

 

 Part 2

 

This is the tutorial many of you have been asking me for, I finally got the time to do it. I hope you’ll enjoy it.

the music might be out of sync in some parts because of the recording, sorry for that.

this was made on After effects using the plugins :
Trapcode particular, Trapcode form, trapcode Soundkeys

 

Keep experimenting !

17 Comments

  1. نحن نفتخرك فيك اخي الكريم ,شكرا

    • شكرا أخي. مرحبا بك

  2. hi!!! i’m going to experiment it! Love your result anyway! what music do you use? :) there are no file ref to download isn’t it?! :) thank you anyway! keep upload templates and tutorials, they are fantastics! *-*

  3. thx oumoumad
    ur my guru

  4. thanks for the tutorial man :)
    But I have a question,I’m trying to add the three ranges of soundkeys,typing this on expression field:

    a=thisComp.layer(“soundkeys”).effect(“Sound Keys”)(“Output 1″);
    b=thisComp.layer(“soundkeys”).effect(“Sound Keys”)(“Output 2″)*1.5;
    c=thisComp.layer(“soundkeys”).effect(“Sound Keys”)(“Output 3″)*1.5;
    y=a+b+c;
    [a,b,c]
    value- [0,y];

    and AE sends me an error alert with this:
    AE warning:
    expression return must be one dimension 1 not 2, exression disabled

    Error occurred at line 0.
    Comp: “Comp 1″
    Layer: 4 (“particles”)
    Property: “Spin Amplitude”

    So, i decided to put only one, the second, and is not moving, it does not working, however with the AE “convert audio to keyframes” function, works, what can I do?

    • Hi mate,

      I think your problem is in the first lines. in order to multiply their value, you must have everything between parentheses ()
      for example, this one :

      thisComp.layer(“soundkeys”).effect(“Sound Keys”)(“Output 2″)*1.5;

      should be like this

      (thisComp.layer(“soundkeys”).effect(“Sound Keys”)(“Output 2″))*1.5;

      I hope this fixed your problem.

  5. HI Oumoumad

    This is such an amazing tutorial for the Trapcode plugin! Thank you so much.

    I am trying desperately to follow your tutorial, however I have a similar problem as mentioned above. The moment I link the Spin Amplitude to SoundKeys Output 1, both the sound value and the Amplitude value goes to 0.0. Therefor my particles are not synced to the music.

    I also noticed that even without the parent function my sound output remains at 0.0 when I scroll through the timeline.

    I also changed the parentheses to all (), its gives an error but does allow particles to emit, but it still doesn’t sync to the music. I have tried everything and its just not working.
    I think my problem may lie in my music properties but i just can’t find anything.

    Please help!

    • after choosing the music range do you see the values change in the sound keys preview? if you do, before linking spin amplitude to the soundkeys output, make sure you click apply in soundkeys parameters, so it will generate the keyframes for the music values in the layer.

  6. شكرااا

  7. assalamu alaikum, hi Oumoumad, where i can to get the plugins? please tell me..

  8. what the music title…? :-)

    • Reflection

  9. oumoumad, i have some problem, the keyframe of the output music is not full, so the animation of particle is not full following the spectrum of music. please help me, what can i do to this problem?

  10. please tell me what wrong with my steps? the graph of the song is not full, so the particular is not dancing fully…

    • I honestly don’t understand your problem mate, please explain it to me more through email using screenshot : oumoumad@gmail.com

Leave a Reply